{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-5747 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-5747 is a high-severity memory corruption vulnerability in AWS Firecracker, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-5747 and fix it if it is affected.\n\nWhat it is: CVE-2026-5747 is a high-severity memory corruption vulnerability in AWS Firecracker, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-5747 in the wild and no public exploit code.\n\nAffected product: AWS Firecracker. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5747/ (Markdown: https://insights.sbomify.com/CVE-2026-5747/index.md)","id":"CVE-2026-5747","markdown":"https://insights.sbomify.com/CVE-2026-5747/index.md","name":"CVE-2026-5747","record":{"aliases":["GHSA-776c-mpj7-jm3r","openSUSE-SU-2026:10561-1"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Firecracker microVM","requires_auth":"high_privilege","summary":"A local guest user can trigger an out-of-bounds write in Firecracker, potentially crashing the VMM or executing code on the host under specific configurations.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"firecracker","vendor":"amazon"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-369","name":"Divide By Zero"}],"description":"An out-of-bounds write issue in the virtio PCI transport in Firecracker 1.13.0 through 1.14.3 and 1.15.0 on x86_64 and aarch64 might allow a local guest user with root privileges to crash the Firecracker VMM process or potentially execute arbitrary code on the host via modification of virtio queue configuration registers after device activation. Achieving code execution on the host requires additional preconditions, such as the use of a custom guest kernel or specific snapshot configurations.\n\nTo remediate this, users should upgrade to Firecracker 1.14.4 or 1.15.1 and later.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Out-of-bounds Write in Firecracker virtio-pci Transport","id":"CVE-2026-5747","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Text Snippets \u003c= 0.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'w' Shortcode Attribute","id":"CVE-2026-5748"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.15.1-1.1"],"introduced":["0"],"last_affected":[],"package":"firecracker","purl":"pkg:rpm/opensuse/firecracker\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10561-1"}],"prev":{"headline":"Libarchive: a null pointer dereference vulnerability exists in the acl parser of libarchive","id":"CVE-2026-5745"},"products":["Firecracker"],"published":"2026-04-07","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-18960","kev_date_added":null,"published":"2019-12-11"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-27174","kev_date_added":null,"published":"2020-10-16"},{"cvss_score":6,"headline":"Arbitrary Host File Overwrite via Symlink in Firecracker Jailer","id":"CVE-2026-1386","kev_date_added":null,"published":"2026-01-23"},{"cvss_score":5.9,"headline":"Denial of service in n/a","id":"CVE-2020-16843","kev_date_added":null,"published":"2020-08-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["AWS"]},"summary":"A local guest user can trigger an out-of-bounds write in Firecracker, potentially crashing the VMM or executing code on the host under specific configurations.","url":"https://insights.sbomify.com/CVE-2026-5747/"}