# CVE-2026-5747: Out-of-bounds Write in Firecracker virtio-pci Transport

> A local guest user can trigger an out-of-bounds write in Firecracker, potentially crashing the VMM or executing code on the host under specific configurations.

- **Severity:** High 8.7 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-776c-mpj7-jm3r, openSUSE-SU-2026:10561-1

## What is CVE-2026-5747?

CVE-2026-5747 is a high-severity memory corruption vulnerability in AWS Firecracker, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An out-of-bounds write issue in the virtio PCI transport in Firecracker 1.13.0 through 1.14.3 and 1.15.0 on x86_64 and aarch64 might allow a local guest user with root privileges to crash the Firecracker VMM process or potentially execute arbitrary code on the host via modification of virtio queue configuration registers after device activation. Achieving code execution on the host requires additional preconditions, such as the use of a custom guest kernel or specific snapshot configurations.

To remediate this, users should upgrade to Firecracker 1.14.4 or 1.15.1 and later.

Weakness: CWE-787 (Out-of-bounds Write), CWE-369 (Divide By Zero)

## Which versions are affected by CVE-2026-5747?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `firecracker` | openSUSE:Tumbleweed | All versions | 1.15.1-1.1 |

Products: Amazon Firecracker.

## How do I fix CVE-2026-5747?

Upgrade to a fixed version.

## Is CVE-2026-5747 being exploited?

There is no known exploitation of CVE-2026-5747 in the wild and no public exploit code.

## Other vulnerabilities in AWS Firecracker

- [CVE-2019-18960](https://insights.sbomify.com/CVE-2019-18960/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-27174](https://insights.sbomify.com/CVE-2020-27174/): Denial of service in n/a (high 7.5)
- [CVE-2026-1386](https://insights.sbomify.com/CVE-2026-1386/): Arbitrary Host File Overwrite via Symlink in Firecracker Jailer (medium 6.0)
- [CVE-2020-16843](https://insights.sbomify.com/CVE-2020-16843/): Denial of service in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5747 and fix it if it is affected.

What it is: CVE-2026-5747 is a high-severity memory corruption vulnerability in AWS Firecracker, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5747 in the wild and no public exploit code.

Affected product: AWS Firecracker. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5747/ (Markdown: https://insights.sbomify.com/CVE-2026-5747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5747
- OSV: https://osv.dev/vulnerability/CVE-2026-5747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5747/
Summaries are generated and may contain mistakes; the official description above is the record.
