CVE-2026-57480 Parse Server: Denial of service via exponential-time processing of deeply nested query operators
Attackers can cause denial of service in Parse Server by sending deeply nested query operators that trigger exponential processing, blocking the event loop.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-57480?
CVE-2026-57480 is a high-severity denial of service vulnerability in parse-community parse-server, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.
Weakness: CWE-407
Which versions are affected by CVE-2026-57480?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.82 |
parse-server npm | All versions | 8.6.82 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.12 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.12 |
parse Bitnami | All versions | 8.6.82, 9.9.1 |
How do I fix CVE-2026-57480?
Upgrade parse-server to a fixed version for your release line: 8.6.82 or 9.9.1-alpha.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-57480 being exploited?
There is no known exploitation of CVE-2026-57480 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-57480, GHSA-cgxm-vr2f-6fj8.