{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse.","exploited":"There is no known exploitation of CVE-2026-57480 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 8.6.82 or 9.9.1-alpha.12.","what":"CVE-2026-57480 is a high-severity denial of service vulnerability in parse-community parse-server, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-57480 and fix it if it is affected.\n\nWhat it is: CVE-2026-57480 is a high-severity denial of service vulnerability in parse-community parse-server, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-57480 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 8.6.82\n- parse-server (npm): affected all versions; fixed in 8.6.82\n- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.12\n- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.12\n- parse (Bitnami): affected all versions; fixed in 8.6.82, 9.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-57480/ (Markdown: https://insights.sbomify.com/CVE-2026-57480/index.md)","id":"CVE-2026-57480","markdown":"https://insights.sbomify.com/CVE-2026-57480/index.md","name":"CVE-2026-57480","record":{"aliases":["BIT-parse-2026-57480","GHSA-cgxm-vr2f-6fj8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server backend","requires_auth":"none","summary":"Attackers can cause denial of service in Parse Server by sending deeply nested query operators that trigger exponential processing, blocking the event loop.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server: Denial of service via exponential-time processing of deeply nested query operators","id":"CVE-2026-57480","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":5,"n_references":7,"next":{"headline":"Parse Server: LiveQuery discloses object data to a subscriber across an ACL read-access change","id":"CVE-2026-57481"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.82","9.9.1"],"introduced":["0","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-57480"},{"ecosystem":"npm","fixed":["8.6.82"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-cgxm-vr2f-6fj8"},{"ecosystem":"npm","fixed":["8.6.82"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-cgxm-vr2f-6fj8"},{"ecosystem":"npm","fixed":["9.9.1-alpha.12"],"introduced":["9.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-cgxm-vr2f-6fj8"},{"ecosystem":"npm","fixed":["9.9.1-alpha.12"],"introduced":["9.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-cgxm-vr2f-6fj8"}],"prev":{"headline":"Deloitte AI Assist for Customer unauthenticated RAG corpus read and write","id":"CVE-2026-57476"},"products":["parse-server"],"published":"2026-07-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["parse-community"]},"summary":"Attackers can cause denial of service in Parse Server by sending deeply nested query operators that trigger exponential processing, blocking the event loop.","url":"https://insights.sbomify.com/CVE-2026-57480/"}