# CVE-2026-57495: AgenticMail: Unauthenticated inbound mail triggers bypassPermissions resume of the operator's Claude Code session (bridge-wake)

> Unauthenticated inbound emails trigger privileged AI agent sessions with bypassed permissions, allowing attackers to execute arbitrary code via prompt injection.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-fq4x-789w-jg5h

## What is CVE-2026-57495?

CVE-2026-57495 is a high-severity missing authorization vulnerability in @agenticmail/claudecode, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AgenticMail gives AI agents real email addresses and phone numbers. In @agenticmail/claudecode prior to version 0.2.39, @agenticmail/codex prior to version 0.1.33, @agenticmail/core prior to version 0.9.43, and @agenticmail/openclaw prior to version 0.5.71, two inbound-mail handlers act on a privileged effect without verifying that the sender is the operator, while a sibling handler in the same repo does. The higher-impact one: any external email routed to the bridge inbox causes the dispatcher to resume the operator's Claude Code session with `permissionMode: 'bypassPermissions'`, embedding the attacker-controlled `from`/`subject`/`preview` verbatim into the prompt the resumed agent reads — an indirect prompt injection into a fully-privileged agent (Bash/Write/Edit/WebFetch + the agenticmail MCP toolbelt) running as the operator's OAuth identity. The sibling operator-query email-reply hook gates the same untrusted-From provenance with `isOperatorReplySender(replyFrom, config.operatorEmail)` (fail-closed); the bridge-wake path — a strictly higher-privilege effect — has no equivalent. @agenticmail/claudecode 0.2.39, @agenticmail/codex 0.1.33, @agenticmail/core 0.9.43, and @agenticmail/openclaw 0.5.71 contain a fix.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-57495?

8 open source packages ship an affected version, including @agenticmail/claudecode, @agenticmail/codex and @agenticmail/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@agenticmail/claudecode` | npm | All versions | 0.2.39 |
| `@agenticmail/claudecode` | npm | All versions | 0.2.39 |
| `@agenticmail/codex` | npm | All versions | 0.1.33 |
| `@agenticmail/codex` | npm | All versions | 0.1.33 |
| `@agenticmail/core` | npm | All versions | 0.9.43 |
| `@agenticmail/core` | npm | All versions | 0.9.43 |
| `@agenticmail/openclaw` | npm | All versions | 0.5.71 |
| `@agenticmail/openclaw` | npm | All versions | 0.5.71 |

## How do I fix CVE-2026-57495?

Upgrade @agenticmail/claudecode to 0.2.39 or later.

## Is CVE-2026-57495 being exploited?

There is no known exploitation of CVE-2026-57495 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57495 and fix it if it is affected.

What it is: CVE-2026-57495 is a high-severity missing authorization vulnerability in @agenticmail/claudecode, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57495 in the wild and no public exploit code.

Affected packages and fixed versions:
- @agenticmail/claudecode (npm): affected all versions; fixed in 0.2.39
- @agenticmail/claudecode (npm): affected all versions; fixed in 0.2.39
- @agenticmail/codex (npm): affected all versions; fixed in 0.1.33
- @agenticmail/codex (npm): affected all versions; fixed in 0.1.33
- @agenticmail/core (npm): affected all versions; fixed in 0.9.43
- @agenticmail/core (npm): affected all versions; fixed in 0.9.43
- @agenticmail/openclaw (npm): affected all versions; fixed in 0.5.71
- @agenticmail/openclaw (npm): affected all versions; fixed in 0.5.71

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57495/ (Markdown: https://insights.sbomify.com/CVE-2026-57495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57495
- OSV: https://osv.dev/vulnerability/CVE-2026-57495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57495/
Summaries are generated and may contain mistakes; the official description above is the record.
