{"answers":{"affected":"2 open source packages ship an affected version, including justhtml.","exploited":"There is no known exploitation of CVE-2026-5751 in the wild and no public exploit code.","fix":"Upgrade justhtml to 1.14.0 or later.","what":"CVE-2026-5751 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-5751 and fix it if it is affected.\n\nWhat it is: CVE-2026-5751 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-5751 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- justhtml (PyPI): affected from 1.13.0; fixed in 1.14.0\n- justhtml (PyPI): affected from 1.13.0; fixed in 1.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5751/ (Markdown: https://insights.sbomify.com/CVE-2026-5751/index.md)","id":"CVE-2026-5751","markdown":"https://insights.sbomify.com/CVE-2026-5751/index.md","name":"CVE-2026-5751","record":{"aliases":["GHSA-3227-3f97-9f2q","GHSA-r758-8hxw-4845"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"HTML sanitization library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via mutation XSS when using custom sanitization policies that preserve foreign namespaces.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"justhtml versions 1.13.0 and earlier contain a parser-differential / mutation cross-site scripting (mXSS) vulnerability when using a custom SanitizationPolicy that preserves foreign namespaces (e.g., drop_foreign_namespaces=False with allowlisted SVG/MathML elements or raw-text containers such as \u003cstyle\u003e). Specially crafted input can sanitize into markup that appears safe but becomes unsafe when re-parsed by a browser or another HTML parser, allowing markup injection. The default safe configuration (sanitize=True) is not affected. Fixed in 1.14.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"justhtml before 1.14.0 Mutation XSS via custom sanitization policies","id":"CVE-2026-5751","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"CVE-2026-5752","id":"CVE-2026-5752"},"packages":[{"ecosystem":"PyPI","fixed":["1.14.0"],"introduced":["1.13.0"],"last_affected":[],"package":"justhtml","purl":null,"source":"GHSA-r758-8hxw-4845"},{"ecosystem":"PyPI","fixed":["1.14.0"],"introduced":["1.13.0"],"last_affected":[],"package":"justhtml","purl":"pkg:pypi/justhtml","source":"GHSA-r758-8hxw-4845"}],"prev":{"headline":"Insecure direct object reference (IDOR) vulnerability in Fullstep","id":"CVE-2026-5750"},"products":["justhtml"],"published":"2026-08-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["EmilStenstrom"]},"summary":"Attackers can execute arbitrary scripts via mutation XSS when using custom sanitization policies that preserve foreign namespaces.","url":"https://insights.sbomify.com/CVE-2026-5751/"}