# CVE-2026-5751: justhtml before 1.14.0 Mutation XSS via custom sanitization policies

> Attackers can execute arbitrary scripts via mutation XSS when using custom sanitization policies that preserve foreign namespaces.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-3227-3f97-9f2q, GHSA-r758-8hxw-4845

## What is CVE-2026-5751?

CVE-2026-5751 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

justhtml versions 1.13.0 and earlier contain a parser-differential / mutation cross-site scripting (mXSS) vulnerability when using a custom SanitizationPolicy that preserves foreign namespaces (e.g., drop_foreign_namespaces=False with allowlisted SVG/MathML elements or raw-text containers such as <style>). Specially crafted input can sanitize into markup that appears safe but becomes unsafe when re-parsed by a browser or another HTML parser, allowing markup injection. The default safe configuration (sanitize=True) is not affected. Fixed in 1.14.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-5751?

2 open source packages ship an affected version, including justhtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `justhtml` | PyPI | From 1.13.0 | 1.14.0 |
| `justhtml` | PyPI | From 1.13.0 | 1.14.0 |

## How do I fix CVE-2026-5751?

Upgrade justhtml to 1.14.0 or later.

## Is CVE-2026-5751 being exploited?

There is no known exploitation of CVE-2026-5751 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5751 and fix it if it is affected.

What it is: CVE-2026-5751 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-5751 in the wild and no public exploit code.

Affected packages and fixed versions:
- justhtml (PyPI): affected from 1.13.0; fixed in 1.14.0
- justhtml (PyPI): affected from 1.13.0; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5751/ (Markdown: https://insights.sbomify.com/CVE-2026-5751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5751
- OSV: https://osv.dev/vulnerability/CVE-2026-5751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5751/
Summaries are generated and may contain mistakes; the official description above is the record.
