CVE-2026-57576 plone.app.dexterity and plone.app.contenttypes have a Denial of Service due to excessive title or description length
Authenticated users can cause denial of service in Plone CMS by creating content with excessively long titles or descriptions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-57576?
CVE-2026-57576 is a medium-severity denial of service vulnerability in plone.app.contenttypes, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
plone.app.dexterity is a content-type system for the Plone content management system, and plone.app.contenttypes provides Plone’s Dexterity-based content types. Plone.app.dexterity versions through 3.2.2, 4.0.0 through 4.1.2, and 5.0.0, and plone.app.contenttypes versions through 3.0.11, 4.0.0 through 4.0.9, and 5.0.0 are vulnerable to denial of service because an authenticated user can create content with excessively long titles, descriptions, or uploaded-file names, causing Plone to become unresponsive and potentially making the resulting content difficult to edit or delete. The vulnerability is patched in plone.app.dexterity versions 3.2.3, 4.1.3, and 5.0.1, and in plone.app.contenttypes versions 3.0.12, 4.0.10, and 5.0.1.
Weakness: CWE-400
Which versions are affected by CVE-2026-57576?
7 open source packages ship an affected version, including plone-app-dexterity and plone.app.dexterity.
| Package | Affected | Fixed in |
|---|---|---|
plone-app-dexterity PyPI | All versions | 3.2.3, 4.1.3, 5.0.1 |
plone-app-dexterity PyPI | All versions | 3.2.3 |
plone-app-dexterity PyPI | From 4.0.0 | 4.1.3 |
plone-app-dexterity PyPI | From 5.0.0 | 5.0.1 |
plone.app.dexterity PyPI | All versions | 3.2.3 |
plone.app.dexterity PyPI | From 4.0.0 | 4.1.3 |
1 more packages
plone.app.dexterity PyPI | From 5.0.0 | 5.0.1 |
How do I fix CVE-2026-57576?
Upgrade plone-app-dexterity to a fixed version for your release line: 3.2.3, 4.1.3 or 5.0.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-57576 being exploited?
There is no known exploitation of CVE-2026-57576 in the wild and no public exploit code.
Sources
Also known as GHSA-5426-92w4-wvhv, PYSEC-2026-4137.