# CVE-2026-57576: plone.app.dexterity and plone.app.contenttypes have a Denial of Service due to excessive title or description length

> Authenticated users can cause denial of service in Plone CMS by creating content with excessively long titles or descriptions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** GHSA-5426-92w4-wvhv, PYSEC-2026-4137

## What is CVE-2026-57576?

CVE-2026-57576 is a medium-severity denial of service vulnerability in plone.app.contenttypes, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

plone.app.dexterity is a content-type system for the Plone content management system, and plone.app.contenttypes provides Plone’s Dexterity-based content types. Plone.app.dexterity versions through 3.2.2, 4.0.0 through 4.1.2, and 5.0.0, and plone.app.contenttypes versions through 3.0.11, 4.0.0 through 4.0.9, and 5.0.0 are vulnerable to denial of service because an authenticated user can create content with excessively long titles, descriptions, or uploaded-file names, causing Plone to become unresponsive and potentially making the resulting content difficult to edit or delete. The vulnerability is patched in plone.app.dexterity versions 3.2.3, 4.1.3, and 5.0.1, and in plone.app.contenttypes versions 3.0.12, 4.0.10, and 5.0.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-57576?

7 open source packages ship an affected version, including plone-app-dexterity and plone.app.dexterity.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone-app-dexterity` | PyPI | All versions | 3.2.3, 4.1.3, 5.0.1 |
| `plone-app-dexterity` | PyPI | All versions | 3.2.3 |
| `plone-app-dexterity` | PyPI | From 4.0.0 | 4.1.3 |
| `plone-app-dexterity` | PyPI | From 5.0.0 | 5.0.1 |
| `plone.app.dexterity` | PyPI | All versions | 3.2.3 |
| `plone.app.dexterity` | PyPI | From 4.0.0 | 4.1.3 |
| `plone.app.dexterity` | PyPI | From 5.0.0 | 5.0.1 |

## How do I fix CVE-2026-57576?

Upgrade plone-app-dexterity to a fixed version for your release line: 3.2.3, 4.1.3 or 5.0.1.

## Is CVE-2026-57576 being exploited?

There is no known exploitation of CVE-2026-57576 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57576 and fix it if it is affected.

What it is: CVE-2026-57576 is a medium-severity denial of service vulnerability in plone.app.contenttypes, published on 22 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-57576 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone-app-dexterity (PyPI): affected all versions; fixed in 3.2.3, 4.1.3, 5.0.1
- plone-app-dexterity (PyPI): affected all versions; fixed in 3.2.3
- plone-app-dexterity (PyPI): affected from 4.0.0; fixed in 4.1.3
- plone-app-dexterity (PyPI): affected from 5.0.0; fixed in 5.0.1
- plone.app.dexterity (PyPI): affected all versions; fixed in 3.2.3
- plone.app.dexterity (PyPI): affected from 4.0.0; fixed in 4.1.3
- plone.app.dexterity (PyPI): affected from 5.0.0; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57576/ (Markdown: https://insights.sbomify.com/CVE-2026-57576/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57576
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57576
- OSV: https://osv.dev/vulnerability/CVE-2026-57576

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57576/
Summaries are generated and may contain mistakes; the official description above is the record.
