CVE-2026-57579 Alchemy: Unauthenticated nested page API leaks restricted & unpublished content
Unauthenticated attackers can access restricted and unpublished page content via the nested page API due to missing authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-57579?
CVE-2026-57579 is a high-severity missing authorization vulnerability in AlchemyCMS alchemy_cms, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Alchemy is an open source content management system engine written in Ruby on Rails. Prior to 7.4.15, 8.0.15, 8.1.14, and 8.2.6, the unauthenticated GET /api/pages/nested endpoint implemented by Api::PagesController#nested in app/controllers/alchemy/api/pages_controller.rb returns an unfiltered page tree because it performs no authorization and does not scope descendants by the caller's ability. Anonymous callers can retrieve restricted and unpublished page metadata that the sibling show action denies. When elements=true is supplied, PageTreeSerializer also returns element and ingredient content from restricted pages because PageTreePreloader and the serializer do not apply an ability check to those records. This issue is fixed in versions 7.4.15, 8.0.15, 8.1.14, and 8.2.6.
Weakness: CWE-862
Which versions are affected by CVE-2026-57579?
8 open source packages ship an affected version, including alchemy_cms.
| Package | Affected | Fixed in |
|---|---|---|
alchemy_cms RubyGems | All versions | 7.4.15 |
alchemy_cms RubyGems | All versions | 7.4.15 |
alchemy_cms RubyGems | From 8.0.0.a | 8.0.15 |
alchemy_cms RubyGems | From 8.0.0.a | 8.0.15 |
alchemy_cms RubyGems | From 8.1.0 | 8.1.14 |
alchemy_cms RubyGems | From 8.1.0 | 8.1.14 |
2 more packages
alchemy_cms RubyGems | From 8.2.0 | 8.2.6 |
alchemy_cms RubyGems | From 8.2.0 | 8.2.6 |
How do I fix CVE-2026-57579?
Upgrade alchemy_cms to a fixed version for your release line: 7.4.15, 8.0.15, 8.1.14 or 8.2.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-57579 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57579 exists.
Sources
Also known as GHSA-mqq5-j7w8-2hgh.