# CVE-2026-57583: OpenZeppelin Contracts Wizard: Line terminators in info.securityContact / info.license can inject lines into generated source

> Attackers can inject malicious code into generated smart contracts via line terminators in metadata fields, requiring specific integration setups.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-9wxg-vf3r-56hc

## What is CVE-2026-57583?

CVE-2026-57583 is a low-severity code injection vulnerability in @openzeppelin contracts-wizard, published on 14 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenZeppelin Contracts Wizard is a web application to interactively build a contract out of components from OpenZeppelin Contracts. Prior to @openzeppelin/wizard 0.10.11, @openzeppelin/wizard-cairo 3.0.1, @openzeppelin/wizard-stellar 0.6.2, and @openzeppelin/wizard-stylus 0.3.1, the setInfo code path prints info.securityContact and info.license verbatim into single-line comments in generated Solidity, Cairo, Stellar/Soroban, and Stylus source. A line terminator ends the comment and causes following input to be emitted as source declarations. Exploitation requires an integration to populate these fields from untrusted input and a user to consume the generated source; normal self-service web, AI assistant, CLI, and self-hosted API use does not cross that trust boundary, shared links cannot set the fields, and no code executes on a Wizard service. This issue affects generated-source integrity only and is fixed in versions 0.10.11, 3.0.1, 0.6.2, and 0.3.1 of the respective packages.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-57583?

8 open source packages ship an affected version, including @openzeppelin/wizard, @openzeppelin/wizard-cairo and @openzeppelin/wizard-stellar.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/wizard` | npm | All versions | 0.10.11 |
| `@openzeppelin/wizard` | npm | All versions | 0.10.11 |
| `@openzeppelin/wizard-cairo` | npm | All versions | 3.0.1 |
| `@openzeppelin/wizard-cairo` | npm | All versions | 3.0.1 |
| `@openzeppelin/wizard-stellar` | npm | All versions | 0.6.2 |
| `@openzeppelin/wizard-stellar` | npm | All versions | 0.6.2 |
| `@openzeppelin/wizard-stylus` | npm | All versions | 0.3.1 |
| `@openzeppelin/wizard-stylus` | npm | All versions | 0.3.1 |

## How do I fix CVE-2026-57583?

Upgrade @openzeppelin/wizard to 0.10.11 or later.

## Is CVE-2026-57583 being exploited?

There is no known exploitation of CVE-2026-57583 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57583 and fix it if it is affected.

What it is: CVE-2026-57583 is a low-severity code injection vulnerability in @openzeppelin contracts-wizard, published on 14 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-57583 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/wizard (npm): affected all versions; fixed in 0.10.11
- @openzeppelin/wizard (npm): affected all versions; fixed in 0.10.11
- @openzeppelin/wizard-cairo (npm): affected all versions; fixed in 3.0.1
- @openzeppelin/wizard-cairo (npm): affected all versions; fixed in 3.0.1
- @openzeppelin/wizard-stellar (npm): affected all versions; fixed in 0.6.2
- @openzeppelin/wizard-stellar (npm): affected all versions; fixed in 0.6.2
- @openzeppelin/wizard-stylus (npm): affected all versions; fixed in 0.3.1
- @openzeppelin/wizard-stylus (npm): affected all versions; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57583/ (Markdown: https://insights.sbomify.com/CVE-2026-57583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57583
- OSV: https://osv.dev/vulnerability/CVE-2026-57583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57583/
Summaries are generated and may contain mistakes; the official description above is the record.
