CVE-2026-57585 MessagePack: Out-of-bounds read/crash on Unpacker reuse after caught error
Attackers can cause a crash via out-of-bounds read when reusing the Unpacker after an error, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-57585?
CVE-2026-57585 is a high-severity use after free vulnerability in msgpack-python, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MessagePack is the serializer implementation for Python msgpack.org. Prior to 1.2.1, there is an Out-of-bounds read/crash on Unpacker reuse after a caught error, potentially leading to a DoS attack. If the Unpacker is used repeatedly after an error occurs, the process may crash with a SEGV. This issue has been fixed in version 1.2.1.
Weakness: CWE-416
Which versions are affected by CVE-2026-57585?
3 open source packages ship an affected version, including msgpack. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
msgpack PyPI | All versions | 1.2.1 |
msgpack PyPI | All versions | 1.2.1 |
msgpack PyPI | All versions | 1.2.1 |
Linux distribution packages (30)
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise Micro 5.3 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Micro 5.4 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Micro 5.5 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 1.0.7-150600.3.5.1 |
python-msgpack SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 1.0.7-150600.3.5.1 |
python-msgpack SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 1.0.7-150400.10.9.1 |
python-msgpack SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 0.5.6-150100.3.6.1 |
python-msgpack SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 1.0.7-150600.3.5.1 |
python-msgpack SUSE:Linux Micro 6.0 | All versions | 1.0.5-2.1 |
python-msgpack SUSE:Linux Micro 6.1 | All versions | 1.0.5-slfo.1.1_2.1 |
python-msgpack-python SUSE:Manager Client Tools 12 | All versions | 0.4.6-8.8.1 |
python-msgpack openSUSE:Leap 16.0 | All versions | 1.1.0-160000.3.1 |
python-msgpack openSUSE:Tumbleweed | All versions | 1.2.1-1.1 |
Products include Msgpack Messagepack.
How do I fix CVE-2026-57585?
Upgrade msgpack to 1.2.1 or later.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2026-57585 being exploited?
There is no known exploitation of CVE-2026-57585 in the wild and no public exploit code.
Other vulnerabilities in msgpack-python
Sources
Also known as AZL-91746, BELL-CVE-2026-57585, CLEANSTART-2026-FV21331, CLEANSTART-2026-KD93591, CLEANSTART-2026-KG31017, CLEANSTART-2026-MV63007 and 39 more.