# CVE-2026-57994: phpMyFAQ - Information Disclosure of Inactive FAQ Content via Public API Endpoints

> Unauthenticated attackers can retrieve inactive or draft FAQ content via public API endpoints due to inconsistent filtering.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-7582-hcc6-fvcg, GHSA-mf8r-wm2w-f8c5

## What is CVE-2026-57994?

CVE-2026-57994 is a medium-severity vulnerability in phpMyFAQ, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ before 4.1.5 applies inconsistent active=yes and publication-date filtering across its public FAQ API endpoints, allowing unauthenticated attackers to retrieve inactive (draft or review-only) FAQ content. Specifically, GET /api/v3.1/faq/{categoryId}/{faqId} returns the inactive FAQ title and full answer, while GET /api/v3.1/faqs/tags/{tagId} and GET /api/v4.0/faqs/tags/{tagId} return the inactive FAQ title and answer preview, disclosing non-public content.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-57994?

4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | From 4.1.0 | 4.1.5 |
| `phpmyfaq/phpmyfaq` | Packagist | From 4.1.0 | 4.1.5 |
| `thorsten/phpmyfaq` | Packagist | From 4.1.0 | 4.1.5 |
| `thorsten/phpmyfaq` | Packagist | From 4.1.0 | 4.1.5 |

## How do I fix CVE-2026-57994?

Upgrade phpmyfaq/phpmyfaq to 4.1.5 or later.

## Is CVE-2026-57994 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57994 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57994 and fix it if it is affected.

What it is: CVE-2026-57994 is a medium-severity vulnerability in phpMyFAQ, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57994 exists.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected from 4.1.0; fixed in 4.1.5
- phpmyfaq/phpmyfaq (Packagist): affected from 4.1.0; fixed in 4.1.5
- thorsten/phpmyfaq (Packagist): affected from 4.1.0; fixed in 4.1.5
- thorsten/phpmyfaq (Packagist): affected from 4.1.0; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57994/ (Markdown: https://insights.sbomify.com/CVE-2026-57994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57994
- OSV: https://osv.dev/vulnerability/CVE-2026-57994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57994/
Summaries are generated and may contain mistakes; the official description above is the record.
