{"answers":{"affected":"4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57995 exists.","fix":"Upgrade phpmyfaq/phpmyfaq to 4.1.5 or later.","what":"CVE-2026-57995 is a high-severity vulnerability in phpMyFAQ, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-57995 and fix it if it is affected.\n\nWhat it is: CVE-2026-57995 is a high-severity vulnerability in phpMyFAQ, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57995 exists.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5\n- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5\n- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-57995/ (Markdown: https://insights.sbomify.com/CVE-2026-57995/index.md)","id":"CVE-2026-57995","markdown":"https://insights.sbomify.com/CVE-2026-57995/index.md","name":"CVE-2026-57995","record":{"aliases":["GHSA-996g-x95h-p2f5","GHSA-pg62-f8g4-4wqh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"FAQ web application","requires_auth":"low_privilege","summary":"Delegated administrators can escalate privileges to full admin by granting themselves arbitrary rights via a missing constraint in group permission updates.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"phpMyFAQ before 4.1.5 contains a privilege escalation vulnerability in GroupController::updatePermissions that allows GROUP_EDIT administrators to grant arbitrary rights to groups without verifying they hold those rights themselves. A delegated administrator can exploit this by assigning high-value permissions to a group they belong to, inheriting those rights and escalating privileges up to full administrative control.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"phpMyFAQ - Privilege Escalation via Missing Self-Rights Constraint in GroupController::updatePermissions","id":"CVE-2026-57995","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"phpMyFAQ - Privilege Escalation via Missing SuperAdmin Guard in user/add Endpoint","id":"CVE-2026-57996"},"packages":[{"ecosystem":"Packagist","fixed":["4.1.5"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-pg62-f8g4-4wqh"},{"ecosystem":"Packagist","fixed":["4.1.5"],"introduced":["0"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-pg62-f8g4-4wqh"},{"ecosystem":"Packagist","fixed":["4.1.5"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":null,"source":"GHSA-pg62-f8g4-4wqh"},{"ecosystem":"Packagist","fixed":["4.1.5"],"introduced":["0"],"last_affected":[],"package":"thorsten/phpmyfaq","purl":"pkg:composer/thorsten/phpmyfaq","source":"GHSA-pg62-f8g4-4wqh"}],"prev":{"headline":"phpMyFAQ - Information Disclosure of Inactive FAQ Content via Public API Endpoints","id":"CVE-2026-57994"},"products":["phpMyFAQ"],"published":"2026-06-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-01","vendors":["phpMyFAQ"]},"summary":"Delegated administrators can escalate privileges to full admin by granting themselves arbitrary rights via a missing constraint in group permission updates.","url":"https://insights.sbomify.com/CVE-2026-57995/"}