# CVE-2026-57995: phpMyFAQ - Privilege Escalation via Missing Self-Rights Constraint in GroupController::updatePermissions

> Delegated administrators can escalate privileges to full admin by granting themselves arbitrary rights via a missing constraint in group permission updates.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jun 2026
- **Updated:** 1 Jul 2026
- **Also known as:** GHSA-996g-x95h-p2f5, GHSA-pg62-f8g4-4wqh

## What is CVE-2026-57995?

CVE-2026-57995 is a high-severity vulnerability in phpMyFAQ, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpMyFAQ before 4.1.5 contains a privilege escalation vulnerability in GroupController::updatePermissions that allows GROUP_EDIT administrators to grant arbitrary rights to groups without verifying they hold those rights themselves. A delegated administrator can exploit this by assigning high-value permissions to a group they belong to, inheriting those rights and escalating privileges up to full administrative control.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-57995?

4 open source packages ship an affected version, including phpmyfaq/phpmyfaq and thorsten/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.5 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.5 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.5 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.5 |

## How do I fix CVE-2026-57995?

Upgrade phpmyfaq/phpmyfaq to 4.1.5 or later.

## Is CVE-2026-57995 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57995 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-57995 and fix it if it is affected.

What it is: CVE-2026-57995 is a high-severity vulnerability in phpMyFAQ, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-57995 exists.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-57995/ (Markdown: https://insights.sbomify.com/CVE-2026-57995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-57995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-57995
- OSV: https://osv.dev/vulnerability/CVE-2026-57995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-57995/
Summaries are generated and may contain mistakes; the official description above is the record.
