# CVE-2026-58076: Apache Airflow exception-node deserialization permits arbitrary callable execution

> A DAG author can achieve remote code execution on the Scheduler or API server by exploiting unguarded import_string calls during exception deserialization.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-58076, GHSA-8prw-8m6x-8w6f, MINI-92m7-f8j7-mm39, PYSEC-2026-3991

## What is CVE-2026-58076?

CVE-2026-58076 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's serialization layer reconstructed exception nodes by calling `import_string()` on a class name taken from the serialized blob and instantiating it with arguments from the same blob, with no restriction on what could be imported. An operator's `executor_config` reaches that branch, so a Dag author could place a value there that causes an arbitrary callable to be imported and invoked -- for example `subprocess.check_output`, or `builtins.eval` on the `builtins`-prefixed variant. The code runs in the **Scheduler**, which reconstructs serialized Dags in its normal loop with no request involved, and in the **API server**, on any authenticated read of the Dag such as `GET /api/v2/dags/{dag_id}/details`. Both are components the Airflow security model states must never execute Dag-author code, and both hold the metadata database credentials and the JWT signing secret. No non-default configuration is required. This is a **different sink from CVE-2026-33264**, which covered only the trigger branch of the same deserializer: deployments that upgraded in response to that advisory are still affected through the exception branch and must upgrade again. Users are advised to upgrade to apache-airflow 3.3.1 or later, which restricts the imported class to a subclass of `BaseException`.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-58076?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `airflow` | Bitnami | From 3.3.0 | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-58076?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-58076 being exploited?

There is no known exploitation of CVE-2026-58076 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58076 and fix it if it is affected.

What it is: CVE-2026-58076 is a high-severity unsafe deserialization vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58076 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- airflow (Bitnami): affected from 3.3.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58076/ (Markdown: https://insights.sbomify.com/CVE-2026-58076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58076
- OSV: https://osv.dev/vulnerability/CVE-2026-58076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58076/
Summaries are generated and may contain mistakes; the official description above is the record.
