CVE-2026-58150 Apache Traffic Server: HTTP/2 requests with Transfer-Encoding are not rejected, allowing request smuggling
Attackers can exploit HTTP/2 request smuggling in Apache Traffic Server to bypass security controls or modify data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58150?
CVE-2026-58150 is a high-severity vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Traffic Server does not reject Transfer-Encoding in HTTP/2 requests, allowing downgrade request smuggling.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Weakness: CWE-444
Which versions are affected by CVE-2026-58150?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2026-58150?
Upgrade to a fixed version.
Is CVE-2026-58150 being exploited?
There is no known exploitation of CVE-2026-58150 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2026-58150, GHSA-5cvm-p8jm-mcrf, UBUNTU-CVE-2026-58150.