CVE-2026-58157 Apache Traffic Server: Improper server-session reuse can expose data across client connections

Medium 6.9 Published Updated

Improper session reuse in Apache Traffic Server allows attackers to expose data across client connections, requiring an upgrade to secure the server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58157?

CVE-2026-58157 is a medium-severity vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Traffic Server can reuse server sessions and tunnels improperly, exposing data across client connections.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-200

Which versions are affected by CVE-2026-58157?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58157?

Upgrade to a fixed version.

Is CVE-2026-58157 being exploited?

There is no known exploitation of CVE-2026-58157 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58157, GHSA-vc32-c93g-p2f6, UBUNTU-CVE-2026-58157.

Is CVE-2026-58157 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free