CVE-2026-58158 Apache Traffic Server: PROXY protocol parsing has port truncation and a stack overflow
Attackers can trigger stack overflow and port truncation via PROXY protocol input, potentially leading to code execution or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58158?
CVE-2026-58158 is a high-severity memory corruption vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Traffic Server mishandles PROXY protocol input, truncating ports and overflowing the stack.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Weakness: CWE-121
Which versions are affected by CVE-2026-58158?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2026-58158?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-58158 being exploited?
There is no known exploitation of CVE-2026-58158 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2026-58158, GHSA-99g5-7fmc-568c, UBUNTU-CVE-2026-58158.