CVE-2026-58161 Apache Traffic Server: Memory-safety errors in TLS and SNI handling can crash the server
Attackers can crash Apache Traffic Server via null dereferences and dangling references in TLS and SNI handling, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58161?
CVE-2026-58161 is a critical vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Traffic Server can crash from null dereferences and dangling references in TLS and SNI handling.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Weakness: CWE-476
Which versions are affected by CVE-2026-58161?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2026-58161?
Upgrade to a fixed version.
Is CVE-2026-58161 being exploited?
There is no known exploitation of CVE-2026-58161 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2026-58161, GHSA-29wv-p4qw-p36r, UBUNTU-CVE-2026-58161.