CVE-2026-58162 Apache Traffic Server: Certifier plugin trusts client SNI when generating certificates
The certifier plugin generates certificates based on unvalidated client SNI, allowing attackers to bypass certificate validation mechanisms.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58162?
CVE-2026-58162 is a high-severity vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Apache Traffic Server certifier plugin generates certificates based on attacker-controlled client SNI.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Weakness: CWE-295
Which versions are affected by CVE-2026-58162?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2026-58162?
Upgrade to a fixed version.
Is CVE-2026-58162 being exploited?
There is no known exploitation of CVE-2026-58162 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2026-58162, GHSA-2w9p-8x38-7x8f, UBUNTU-CVE-2026-58162.