CVE-2026-58167 Nightingale < 9.0.0-beta.2 - Datasource Credential Disclosure to Low-Privilege Users
Low-privilege users can view plaintext database credentials and tokens via an unsecured API endpoint, exposing downstream systems to compromise.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58167?
CVE-2026-58167 is a high-severity vulnerability in ccfos nightingale, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Nightingale (n9e) before 9.0.0-beta.2 exposes full datasource configurations, including plaintext database passwords, HTTP bearer tokens, HTTP basic-auth passwords, and mTLS client keys, to any authenticated low-privilege (Standard role) user through POST /api/n9e/datasource/list. The route is registered without an admin authorization gate, unlike the sibling datasource mutation routes, and the open-source DatasourceFilter does not redact secret fields, so the secret-bearing settings, http, and auth objects are serialized in the response. The disclosed credentials enable access to the connected downstream systems.
Weakness: CWE-862
Which versions are affected by CVE-2026-58167?
6 open source packages ship an affected version, including github.com/ccfos/nightingale/v6, github.com/ccfos/nightingale and github.com/ccfos/nightingale/v4.
| Package | Affected | Fixed in |
|---|---|---|
github.com/ccfos/nightingale/v6 Go | All versions | 6.7.3-0.20260528033214-762819fbaa23 |
github.com/ccfos/nightingale/v6 Go | All versions | 6.7.3-0.20260528033214-762819fbaa23 |
github.com/ccfos/nightingale/v6 Go | All versions | 6.7.3-0.20260528033214-762819fbaa23 |
github.com/ccfos/nightingale Go | All versions | None |
github.com/ccfos/nightingale/v4 Go | All versions | None |
github.com/ccfos/nightingale/v5 Go | All versions | None |
How do I fix CVE-2026-58167?
Upgrade github.com/ccfos/nightingale/v6 to 6.7.3-0.20260528033214-762819fbaa23 or later.
Is CVE-2026-58167 being exploited?
There is no known exploitation of CVE-2026-58167 in the wild and no public exploit code.
Sources
Also known as GHSA-27c6-wp53-387x, GO-2026-6638.