# CVE-2026-58167: Nightingale < 9.0.0-beta.2 - Datasource Credential Disclosure to Low-Privilege Users

> Low-privilege users can view plaintext database credentials and tokens via an unsecured API endpoint, exposing downstream systems to compromise.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-27c6-wp53-387x, GO-2026-6638

## What is CVE-2026-58167?

CVE-2026-58167 is a high-severity vulnerability in ccfos nightingale, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nightingale (n9e) before 9.0.0-beta.2 exposes full datasource configurations, including plaintext database passwords, HTTP bearer tokens, HTTP basic-auth passwords, and mTLS client keys, to any authenticated low-privilege (Standard role) user through POST /api/n9e/datasource/list. The route is registered without an admin authorization gate, unlike the sibling datasource mutation routes, and the open-source DatasourceFilter does not redact secret fields, so the secret-bearing settings, http, and auth objects are serialized in the response. The disclosed credentials enable access to the connected downstream systems.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-58167?

6 open source packages ship an affected version, including github.com/ccfos/nightingale/v6, github.com/ccfos/nightingale and github.com/ccfos/nightingale/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ccfos/nightingale/v6` | Go | All versions | 6.7.3-0.20260528033214-762819fbaa23 |
| `github.com/ccfos/nightingale/v6` | Go | All versions | 6.7.3-0.20260528033214-762819fbaa23 |
| `github.com/ccfos/nightingale/v6` | Go | All versions | 6.7.3-0.20260528033214-762819fbaa23 |
| `github.com/ccfos/nightingale` | Go | All versions | None |
| `github.com/ccfos/nightingale/v4` | Go | All versions | None |
| `github.com/ccfos/nightingale/v5` | Go | All versions | None |

## How do I fix CVE-2026-58167?

Upgrade github.com/ccfos/nightingale/v6 to 6.7.3-0.20260528033214-762819fbaa23 or later.

## Is CVE-2026-58167 being exploited?

There is no known exploitation of CVE-2026-58167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58167 and fix it if it is affected.

What it is: CVE-2026-58167 is a high-severity vulnerability in ccfos nightingale, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58167 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ccfos/nightingale/v6 (Go): affected all versions; fixed in 6.7.3-0.20260528033214-762819fbaa23
- github.com/ccfos/nightingale/v6 (Go): affected all versions; fixed in 6.7.3-0.20260528033214-762819fbaa23
- github.com/ccfos/nightingale/v6 (Go): affected all versions; fixed in 6.7.3-0.20260528033214-762819fbaa23
- github.com/ccfos/nightingale (Go): affected all versions; no fix listed
- github.com/ccfos/nightingale/v4 (Go): affected all versions; no fix listed
- github.com/ccfos/nightingale/v5 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58167/ (Markdown: https://insights.sbomify.com/CVE-2026-58167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58167
- OSV: https://osv.dev/vulnerability/CVE-2026-58167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58167/
Summaries are generated and may contain mistakes; the official description above is the record.
