{"answers":{"affected":"3 open source packages ship an affected version, including deeptutor.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58168 exists.","fix":"Upgrade deeptutor to 1.4.10 or later.","what":"CVE-2026-58168 is a high-severity missing authorization vulnerability in HKUDS DeepTutor, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-58168 and fix it if it is affected.\n\nWhat it is: CVE-2026-58168 is a high-severity missing authorization vulnerability in HKUDS DeepTutor, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58168 exists.\n\nAffected packages and fixed versions:\n- deeptutor (PyPI): affected all versions; fixed in 1.4.10\n- deeptutor (PyPI): affected all versions; fixed in 1.4.10\n- deeptutor (PyPI): affected all versions; fixed in 1.4.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58168/ (Markdown: https://insights.sbomify.com/CVE-2026-58168/index.md)","id":"CVE-2026-58168","markdown":"https://insights.sbomify.com/CVE-2026-58168/index.md","name":"CVE-2026-58168","record":{"aliases":["GHSA-jg88-rvpc-qvxj","PYSEC-2026-4206"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"DeepTutor AI platform","requires_auth":"low_privilege","summary":"Low-privilege users can invoke unrestricted MCP tools due to insecure default authorization logic, potentially accessing sensitive system resources.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"DeepTutor before version 1.4.10 contains an authorization bypass vulnerability that allows low-privilege users to invoke unrestricted MCP tools due to the allowed_mcp_tools function returning None instead of a denied result when mcp_tools is omitted from a user's grant in deeptutor/multi_user/tool_access.py. Attackers or prompt-injected content acting within a user session can enumerate and invoke any configured MCP tool, including filesystem, shell, and browser servers, gaining unauthorized access to sensitive deployment resources.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"DeepTutor \u003c 1.4.10 - Insecure Default Grants Unrestricted MCP Tool Access to Non-Admin Users","id":"CVE-2026-58168","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Auth bypass in Vibe-Trading","id":"CVE-2026-58169"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.10"],"introduced":["0"],"last_affected":[],"package":"deeptutor","purl":null,"source":"GHSA-jg88-rvpc-qvxj"},{"ecosystem":"PyPI","fixed":["1.4.10"],"introduced":["0"],"last_affected":[],"package":"deeptutor","purl":"pkg:pypi/deeptutor","source":"GHSA-jg88-rvpc-qvxj"},{"ecosystem":"PyPI","fixed":["1.4.10"],"introduced":["0"],"last_affected":[],"package":"deeptutor","purl":"pkg:pypi/deeptutor","source":"PYSEC-2026-4206"}],"prev":{"headline":"Nightingale \u003c 9.0.0-beta.2 - Datasource Credential Disclosure to Low-Privilege Users","id":"CVE-2026-58167"},"products":["DeepTutor"],"published":"2026-06-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["HKUDS"]},"summary":"Low-privilege users can invoke unrestricted MCP tools due to insecure default authorization logic, potentially accessing sensitive system resources.","url":"https://insights.sbomify.com/CVE-2026-58168/"}