# CVE-2026-58168: DeepTutor < 1.4.10 - Insecure Default Grants Unrestricted MCP Tool Access to Non-Admin Users

> Low-privilege users can invoke unrestricted MCP tools due to insecure default authorization logic, potentially accessing sensitive system resources.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-jg88-rvpc-qvxj, PYSEC-2026-4206

## What is CVE-2026-58168?

CVE-2026-58168 is a high-severity missing authorization vulnerability in HKUDS DeepTutor, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DeepTutor before version 1.4.10 contains an authorization bypass vulnerability that allows low-privilege users to invoke unrestricted MCP tools due to the allowed_mcp_tools function returning None instead of a denied result when mcp_tools is omitted from a user's grant in deeptutor/multi_user/tool_access.py. Attackers or prompt-injected content acting within a user session can enumerate and invoke any configured MCP tool, including filesystem, shell, and browser servers, gaining unauthorized access to sensitive deployment resources.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-58168?

3 open source packages ship an affected version, including deeptutor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deeptutor` | PyPI | All versions | 1.4.10 |
| `deeptutor` | PyPI | All versions | 1.4.10 |
| `deeptutor` | PyPI | All versions | 1.4.10 |

## How do I fix CVE-2026-58168?

Upgrade deeptutor to 1.4.10 or later.

## Is CVE-2026-58168 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58168 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58168 and fix it if it is affected.

What it is: CVE-2026-58168 is a high-severity missing authorization vulnerability in HKUDS DeepTutor, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58168 exists.

Affected packages and fixed versions:
- deeptutor (PyPI): affected all versions; fixed in 1.4.10
- deeptutor (PyPI): affected all versions; fixed in 1.4.10
- deeptutor (PyPI): affected all versions; fixed in 1.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58168/ (Markdown: https://insights.sbomify.com/CVE-2026-58168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58168
- OSV: https://osv.dev/vulnerability/CVE-2026-58168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58168/
Summaries are generated and may contain mistakes; the official description above is the record.
