CVE-2026-58177 Apache Traffic Server: Memory-safety and path-traversal errors in the Cripts framework

High 8.3 Published Updated

Attackers can exploit memory corruption and path traversal flaws in the Cripts framework to execute code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-58177?

CVE-2026-58177 is a high-severity memory corruption vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server Cripts framework has out-of-bounds writes, path traversal, and use-after-free errors.

This issue affects Apache Traffic Server: from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 10.1.4, which fix the issue.

Weakness: CWE-787

Which versions are affected by CVE-2026-58177?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58177?

No fix has been published for CVE-2026-58177 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-58177 being exploited?

There is no known exploitation of CVE-2026-58177 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58177, GHSA-xm2f-jc7r-hmhj, UBUNTU-CVE-2026-58177.

Is CVE-2026-58177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free