CVE-2026-58178 Apache Traffic Server: ESI plugin allows uncontrolled recursion and server-side request forgery

High 8.2 Published Updated

Attackers can trigger uncontrolled recursion and fetch arbitrary URLs via the ESI plugin, leading to server-side request forgery and potential denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58178?

CVE-2026-58178 is a high-severity server-side request forgery vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server ESI plugin can recurse without bound and fetch attacker-controlled URLs.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-674

Which versions are affected by CVE-2026-58178?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58178?

Upgrade to a fixed version.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-58178 being exploited?

There is no known exploitation of CVE-2026-58178 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58178, GHSA-jmf6-wg5m-793g, UBUNTU-CVE-2026-58178.

Is CVE-2026-58178 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free