CVE-2026-58180 Apache Traffic Server: txn_box plugin overflows the stack from attacker input

High 8.2 Published Updated

Attacker-controlled input causes stack overflow in the txn_box plugin, potentially leading to code execution or service disruption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58180?

CVE-2026-58180 is a high-severity memory corruption vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server txn_box plugin overflows the stack from attacker-controlled input.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-121

Which versions are affected by CVE-2026-58180?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58180?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-58180 being exploited?

There is no known exploitation of CVE-2026-58180 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58180, GHSA-jxxq-f4qq-497f, UBUNTU-CVE-2026-58180.

Is CVE-2026-58180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free