CVE-2026-58181 Apache Traffic Server: uri_signing and url_sig plugins can exhaust the stack or crash

High 8.2 Published Updated

Attacker input can exhaust the stack or crash Apache Traffic Server via uri_signing and url_sig plugins, causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58181?

CVE-2026-58181 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server uri_signing and url_sig plugins can exhaust the stack or crash on attacker input.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-121

Which versions are affected by CVE-2026-58181?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58181?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-58181 being exploited?

There is no known exploitation of CVE-2026-58181 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58181, GHSA-2vfg-xrq7-ffvf, UBUNTU-CVE-2026-58181.

Is CVE-2026-58181 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free