CVE-2026-58182 Apache Traffic Server: ts_lua plugin has initialization and resource-handling errors

High 8.2 Published Updated

Attackers can cause denial of service in Apache Traffic Server via the ts_lua plugin due to improper initialization and resource handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58182?

CVE-2026-58182 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server ts_lua plugin mishandles initialization, transform context, and per-instance state.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-400

Which versions are affected by CVE-2026-58182?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58182?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-58182 being exploited?

There is no known exploitation of CVE-2026-58182 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58182, GHSA-x56q-2cqh-7326, UBUNTU-CVE-2026-58182.

Is CVE-2026-58182 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free