CVE-2026-58183 Apache Traffic Server: prefetch plugin can crash on attacker-influenced input

High 8.2 Published Updated

Attacker can crash Apache Traffic Server via the prefetch plugin using crafted input, requiring an upgrade to restore service availability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58183?

CVE-2026-58183 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server prefetch plugin can crash when processing attacker-influenced input.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-20

Which versions are affected by CVE-2026-58183?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58183?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-58183 being exploited?

There is no known exploitation of CVE-2026-58183 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58183, GHSA-5gc7-q59c-j3fj, UBUNTU-CVE-2026-58183.

Is CVE-2026-58183 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free