# CVE-2026-58183: Apache Traffic Server: prefetch plugin can crash on attacker-influenced input

> Attacker can crash Apache Traffic Server via the prefetch plugin using crafted input, requiring an upgrade to restore service availability.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2026
- **Updated:** 1 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-58183, GHSA-5gc7-q59c-j3fj, UBUNTU-CVE-2026-58183

## What is CVE-2026-58183?

CVE-2026-58183 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Traffic Server prefetch plugin can crash when processing attacker-influenced input.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-58183?

It affects 1 product.


Products: Apache Traffic Server.

## How do I fix CVE-2026-58183?

Upgrade to a fixed version.

## Is CVE-2026-58183 being exploited?

There is no known exploitation of CVE-2026-58183 in the wild and no public exploit code.

## Other vulnerabilities in Apache Traffic Server

- [CVE-2014-3525](https://insights.sbomify.com/CVE-2014-3525/): Other in n/a (critical 10.0)
- [CVE-2021-43082](https://insights.sbomify.com/CVE-2021-43082/): heap-buffer-overflow with stats-over-http plugin (critical 9.8)
- [CVE-2021-35474](https://insights.sbomify.com/CVE-2021-35474/): Dynamic stack buffer overflow in cachekey plugin (critical 9.8)
- [CVE-2019-17559](https://insights.sbomify.com/CVE-2019-17559/): Other in Apache Traffic Server (critical 9.8)
- [CVE-2019-17565](https://insights.sbomify.com/CVE-2019-17565/): Other in Apache Traffic Server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58183 and fix it if it is affected.

What it is: CVE-2026-58183 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58183 in the wild and no public exploit code.

Affected product: Apache Traffic Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58183/ (Markdown: https://insights.sbomify.com/CVE-2026-58183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58183
- OSV: https://osv.dev/vulnerability/CVE-2026-58183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58183/
Summaries are generated and may contain mistakes; the official description above is the record.
