CVE-2026-58185 Apache Traffic Server: Use-after-free in the intercept plugin

High 8.2 Published Updated

A use-after-free vulnerability in the Apache Traffic Server intercept plugin allows attackers to potentially execute code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58185?

CVE-2026-58185 is a high-severity use after free vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Traffic Server intercept plugin has a use-after-free.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.

Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Weakness: CWE-416

Which versions are affected by CVE-2026-58185?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-58185?

Upgrade to a fixed version.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2026-58185 being exploited?

There is no known exploitation of CVE-2026-58185 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-58185, GHSA-qw2q-phpw-69hv, UBUNTU-CVE-2026-58185.

Is CVE-2026-58185 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free