CVE-2026-58186 Apache Traffic Server: webp_transform plugin decodes unsafely and mislabels degraded responses
The webp_transform plugin in Apache Traffic Server decodes images unsafely and serves mislabeled cacheable responses, potentially exposing data or bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58186?
CVE-2026-58186 is a high-severity vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Apache Traffic Server webp_transform plugin can decode unsafely and serve mislabeled, cacheable responses.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-58186?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2026-58186?
Upgrade to a fixed version.
Is CVE-2026-58186 being exploited?
There is no known exploitation of CVE-2026-58186 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2026-58186, GHSA-fr5w-2rg3-6qp3, UBUNTU-CVE-2026-58186.