# CVE-2026-58198: ChatterBot: Symlink-Following Arbitrary Write via UbuntuCorpusTrainer

> A local attacker can exploit a symlink race condition in UbuntuCorpusTrainer to write arbitrary files to attacker-chosen directories.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-wvrh-2f4m-924v

## What is CVE-2026-58198?

CVE-2026-58198 is a medium-severity path traversal vulnerability in gunthercox ChatterBot, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

ChatterBot is a machine learning, conversational dialog engine for creating chat bots. Prior to 1.2.14, UbuntuCorpusTrainer.extract() uses a predictable home-rooted output directory (~/ubuntu_data/ubuntu_dialogs) with a check-then-create pattern followed by tar.extractall(path=self.data_path), allowing a local attacker who pre-plants a symlink at the predictable path to cause archive contents to be written through the symlink to an attacker-chosen directory. This issue is fixed in version 1.2.14.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-58198?

2 open source packages ship an affected version, including ChatterBot and chatterbot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ChatterBot` | PyPI | All versions | 1.2.14 |
| `chatterbot` | PyPI | All versions | 1.2.14 |

## How do I fix CVE-2026-58198?

Upgrade ChatterBot to 1.2.14 or later.

## Is CVE-2026-58198 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58198 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58198 and fix it if it is affected.

What it is: CVE-2026-58198 is a medium-severity path traversal vulnerability in gunthercox ChatterBot, published on 9 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58198 exists.

Affected packages and fixed versions:
- ChatterBot (PyPI): affected all versions; fixed in 1.2.14
- chatterbot (PyPI): affected all versions; fixed in 1.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58198/ (Markdown: https://insights.sbomify.com/CVE-2026-58198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58198
- OSV: https://osv.dev/vulnerability/CVE-2026-58198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58198/
Summaries are generated and may contain mistakes; the official description above is the record.
