CVE-2026-58200 @jhb.software/payload-cloudinary-plugin: Arbitrary Cloudinary API Parameter Signing

High 7.1 Published Updated

Authenticated users can generate valid Cloudinary signatures for unauthorized parameters, allowing asset replacement and unauthorized uploads when clientUploads is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-58200?

CVE-2026-58200 is a high-severity missing authorization vulnerability in jhb-software payload-plugins, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Payload Plugins is a collection of plugins designed to enhance Payload CMS. From 0.3.0 until 0.4.0, @jhb.software/payload-cloudinary-plugin deployments with clientUploads enabled expose POST /api/cloudinary-generate-signature, whose handler in cloudinary/src/getGenerateSignature.ts passes attacker-controlled body.paramsToSign directly to cloudinary.utils.api_sign_request without a key allowlist, collection policy, timestamp freshness check, or configured-folder enforcement. Any authenticated Payload user can obtain a valid Cloudinary HMAC-SHA1 signature for unauthorized parameters such as overwrite, type, notification_url, invalidate, folder, and public_id. The signature can authorize asset replacement, upload visibility changes, callbacks to attacker-selected URLs, cache invalidation, and uploads outside the intended folder. The client-visible Cloudinary API key is expected by the upload design, but the unrestricted server-side signature supplies the authorization value needed to complete these operations. This vulnerability is fixed in 0.4.0.

Weakness: CWE-347

Which versions are affected by CVE-2026-58200?

2 open source packages ship an affected version, including @jhb.software/payload-cloudinary-plugin.

PackageAffectedFixed in
@jhb.software/payload-cloudinary-plugin npmFrom 0.3.00.4.0
@jhb.software/payload-cloudinary-plugin npmFrom 0.3.00.4.0

How do I fix CVE-2026-58200?

Upgrade @jhb.software/payload-cloudinary-plugin to 0.4.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-58200 being exploited?

There is no known exploitation of CVE-2026-58200 in the wild and no public exploit code.

Sources

Also known as GHSA-h5x8-xp6m-x6q4.

Is CVE-2026-58200 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free