CVE-2026-58207 NATS Server: Remote crash via integer overflow in Connz pagination

High 7.7 Published Updated

A remote attacker can crash the NATS server by sending crafted pagination parameters that cause an integer overflow, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58207?

CVE-2026-58207 is a high-severity vulnerability in nats-io nats-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client able to send account-scoped connection monitoring requests could crash the server by supplying Connz pagination Offset and Limit values that overflowed internal arithmetic before the response window was safely bounded. This issue is fixed in versions 2.14.3 and 2.12.12.

Weakness: CWE-190

Which versions are affected by CVE-2026-58207?

It affects 1 product.

Products include Linuxfoundation Nats-Server.

How do I fix CVE-2026-58207?

Upgrade to a fixed version.

Is CVE-2026-58207 being exploited?

There is no known exploitation of CVE-2026-58207 in the wild and no public exploit code.

Sources

Also known as AZL-92241, DEBIAN-CVE-2026-58207, GHSA-q59r-vq66-pxc2, UBUNTU-CVE-2026-58207.

Is CVE-2026-58207 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free