{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-58207 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-58207 is a high-severity vulnerability in nats-io nats-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-58207 and fix it if it is affected.\n\nWhat it is: CVE-2026-58207 is a high-severity vulnerability in nats-io nats-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-58207 in the wild and no public exploit code.\n\nAffected product: nats-io nats-server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58207/ (Markdown: https://insights.sbomify.com/CVE-2026-58207/index.md)","id":"CVE-2026-58207","markdown":"https://insights.sbomify.com/CVE-2026-58207/index.md","name":"CVE-2026-58207","record":{"aliases":["AZL-92241","DEBIAN-CVE-2026-58207","GHSA-q59r-vq66-pxc2","UBUNTU-CVE-2026-58207"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"NATS messaging server","requires_auth":"low_privilege","summary":"A remote attacker can crash the NATS server by sending crafted pagination parameters that cause an integer overflow, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nats-server","vendor":"linuxfoundation"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client able to send account-scoped connection monitoring requests could crash the server by supplying Connz pagination Offset and Limit values that overflowed internal arithmetic before the response window was safely bounded. This issue is fixed in versions 2.14.3 and 2.12.12.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NATS Server: Remote crash via integer overflow in Connz pagination","id":"CVE-2026-58207","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"NATS Server: MQTT-over-WebSocket Path Can Crash WebSocket-Only JetStream Servers Before MQTT Is Enabled","id":"CVE-2026-58208"},"packages":[],"prev":{"headline":"GRR has a Reflected XSS issue","id":"CVE-2026-58205"},"products":["nats-server"],"published":"2026-07-08","related":[{"cvss_score":9.8,"headline":"NATS nats-server allows directory traversal via unintended path to a management action","id":"CVE-2022-28357","kev_date_added":null,"published":"2023-09-19"},{"cvss_score":8.8,"headline":"NATS Server: Route API Auth Bypass","id":"CVE-2026-58253","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":8.8,"headline":"Incorrect Authorization in NATS nats-server","id":"CVE-2022-24450","kev_date_added":null,"published":"2022-02-08"},{"cvss_score":8.6,"headline":"NATS has MQTT plaintext password disclosure","id":"CVE-2026-33216","kev_date_added":null,"published":"2026-03-25"},{"cvss_score":7.5,"headline":"NATS Server: MQTT partial CONNECT packets can exhaust pre-auth memory","id":"CVE-2026-58210","kev_date_added":null,"published":"2026-07-08"},{"cvss_score":7.5,"headline":"NATS Server: Pre-auth server crash via double INFO in leafnode handshake","id":"CVE-2026-58250","kev_date_added":null,"published":"2026-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["nats-io"]},"summary":"A remote attacker can crash the NATS server by sending crafted pagination parameters that cause an integer overflow, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-58207/"}