# CVE-2026-58255: Cronicle is a multi-server task scheduler and runner, with a web based front-end UI.


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-9xpg-9w3g-mpwj

## What is CVE-2026-58255?

CVE-2026-58255 is a high-severity vulnerability in jhuckaby Cronicle, published on 27 Oct 2026. 

### Official description

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.121, a non-administrator user or scoped API key with `create_events` and `run_events` privileges can inject top-level `uid` and `gid` fields through `/api/app/create_event` or `/api/app/update_event`. In `lib/api.js`, `requireValidEventData` uses `validateOptionalParams` as a partial allow-list that silently passes unknown keys, storing the injected fields verbatim. In `lib/job.js`, `launchJob` copies the whole event into the job, and a plugin `uid` overrides the event `uid` only when the plugin defines one. The default `shellplug` and `urlplug` plugins do not define a `uid`, so the event-controlled identity survives into child-process launch. On a root-daemon installation, this lets a low-privileged user run jobs as arbitrary users, including root, bypassing the otherwise administrator-only run-as-user control. This API-side event injection is distinct from the job-output `uid`/`gid` injection addressed by CVE-2026-39401. This issue is fixed in version 0.9.121.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-58255?


## How do I fix CVE-2026-58255?

No fix has been published for CVE-2026-58255 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58255 being exploited?

There is no known exploitation of CVE-2026-58255 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58255 and fix it if it is affected.

What it is: CVE-2026-58255 is a high-severity vulnerability in jhuckaby Cronicle, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-58255 in the wild and no public exploit code.

Affected product: jhuckaby Cronicle. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58255/ (Markdown: https://insights.sbomify.com/CVE-2026-58255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58255
- OSV: https://osv.dev/vulnerability/CVE-2026-58255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58255/
Summaries are generated and may contain mistakes; the official description above is the record.
