# CVE-2026-58256: GRR vulnerable to Remote Code Execution Via PHP Code Injection


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-fp4f-xmw6-5jf8

## What is CVE-2026-58256?

CVE-2026-58256 is a critical vulnerability in JeromeDevome GRR, published on 27 Oct 2026. 

### Official description

GRR is a resource management and reservation application. Prior to the advisory-reported fixed version 4.5.0, an administrator can inject malicious PHP through LDAP connector configuration parameters such as `ldap_filter`, poisoning `/personnalisation/config_ldap.inc.php` and permitting remote code execution. The administrator must first successfully connect to an LDAP server, which can be attacker-controlled, and then submit malicious input on the subsequent connector settings page. The advisory reports this issue as fixed in version 4.5.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-58256?


## How do I fix CVE-2026-58256?

No fix has been published for CVE-2026-58256 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58256 being exploited?

There is no known exploitation of CVE-2026-58256 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58256 and fix it if it is affected.

What it is: CVE-2026-58256 is a critical vulnerability in JeromeDevome GRR, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-58256 in the wild and no public exploit code.

Affected product: JeromeDevome GRR. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58256/ (Markdown: https://insights.sbomify.com/CVE-2026-58256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58256
- OSV: https://osv.dev/vulnerability/CVE-2026-58256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58256/
Summaries are generated and may contain mistakes; the official description above is the record.
