# CVE-2026-58257: GRR vulnerable to Arbitrary File Read and Deletion


- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-p8vm-f8mr-q7w7

## What is CVE-2026-58257?

CVE-2026-58257 is a high-severity vulnerability in JeromeDevome GRR, published on 27 Oct 2026. 

### Official description

GRR is a resource management and reservation application. Prior to the advisory-reported fixed version 4.5.0, the database restoration feature fails to enforce or validate file paths. A user with administrator privileges can manipulate the input to read or delete arbitrary files on the server, causing sensitive file disclosure and denial of service through file deletion. The impact is amplified when the server runs with elevated privileges. The advisory reports this issue as fixed in version 4.5.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-58257?


## How do I fix CVE-2026-58257?

No fix has been published for CVE-2026-58257 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58257 being exploited?

There is no known exploitation of CVE-2026-58257 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58257 and fix it if it is affected.

What it is: CVE-2026-58257 is a high-severity vulnerability in JeromeDevome GRR, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-58257 in the wild and no public exploit code.

Affected product: JeromeDevome GRR. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58257/ (Markdown: https://insights.sbomify.com/CVE-2026-58257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58257
- OSV: https://osv.dev/vulnerability/CVE-2026-58257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58257/
Summaries are generated and may contain mistakes; the official description above is the record.
