CVE-2026-58266 Anki: User scripts in iframes have access to the internal Anki API

Medium 6.5 Published Updated

A malicious imported card package can access the internal API to read arbitrary files and exfiltrate them due to insufficient iframe isolation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-58266?

CVE-2026-58266 is a medium-severity missing authorization vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.4, Anki's webview-based pages communicate with the Rust backend using an internal localhost API, and user scripts included via iframes in the editor can access this API despite protections intended to block reviewer and editor scripts. A malicious imported card package with an embedded iframe can use exposed API methods such as getImageForOcclusion to read arbitrary files accessible to the Anki process and exfiltrate them over the network. This issue is fixed in version 25.09.4.

Weakness: CWE-346

Which versions are affected by CVE-2026-58266?

2 open source packages ship an affected version, including aqt.

PackageAffectedFixed in
aqt PyPIAll versions25.9.4
aqt PyPIAll versions25.9.4

How do I fix CVE-2026-58266?

Upgrade aqt to 25.9.4 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-58266 being exploited?

There is no known exploitation of CVE-2026-58266 in the wild and no public exploit code.

Sources

Also known as GHSA-cw6h-ffmh-x6vh, UBUNTU-CVE-2026-58266.

Is CVE-2026-58266 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free