{"answers":{"affected":"2 open source packages ship an affected version, including aqt.","exploited":"There is no known exploitation of CVE-2026-58266 in the wild and no public exploit code.","fix":"Upgrade aqt to 25.9.4 or later.","what":"CVE-2026-58266 is a medium-severity missing authorization vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-58266 and fix it if it is affected.\n\nWhat it is: CVE-2026-58266 is a medium-severity missing authorization vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-58266 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aqt (PyPI): affected all versions; fixed in 25.9.4\n- aqt (PyPI): affected all versions; fixed in 25.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58266/ (Markdown: https://insights.sbomify.com/CVE-2026-58266/index.md)","id":"CVE-2026-58266","markdown":"https://insights.sbomify.com/CVE-2026-58266/index.md","name":"CVE-2026-58266","record":{"aliases":["GHSA-cw6h-ffmh-x6vh","UBUNTU-CVE-2026-58266"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Anki flashcard application","requires_auth":"none","summary":"A malicious imported card package can access the internal API to read arbitrary files and exfiltrate them due to insufficient iframe isolation.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-346","name":"Origin Validation Error"}],"description":"Anki is a program for creating and reviewing flashcards. Prior to 25.09.4, Anki's webview-based pages communicate with the Rust backend using an internal localhost API, and user scripts included via iframes in the editor can access this API despite protections intended to block reviewer and editor scripts. A malicious imported card package with an embedded iframe can use exposed API methods such as getImageForOcclusion to read arbitrary files accessible to the Anki process and exfiltrate them over the network. This issue is fixed in version 25.09.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Anki: User scripts in iframes have access to the internal Anki API","id":"CVE-2026-58266","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"SIPGO: DoS via unvalidated Content-Length in the stream parser","id":"CVE-2026-58268"},"packages":[{"ecosystem":"PyPI","fixed":["25.9.4"],"introduced":["0"],"last_affected":[],"package":"aqt","purl":null,"source":"GHSA-cw6h-ffmh-x6vh"},{"ecosystem":"PyPI","fixed":["25.9.4"],"introduced":["0"],"last_affected":[],"package":"aqt","purl":"pkg:pypi/aqt","source":"GHSA-cw6h-ffmh-x6vh"}],"prev":{"headline":"FluidSynth: Heap-based buffer overrun","id":"CVE-2026-58264"},"products":["anki"],"published":"2026-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-08","vendors":["ankitects"]},"summary":"A malicious imported card package can access the internal API to read arbitrary files and exfiltrate them due to insufficient iframe isolation.","url":"https://insights.sbomify.com/CVE-2026-58266/"}