# CVE-2026-58268: SIPGO: DoS via unvalidated Content-Length in the stream parser

> An unauthenticated attacker can cause denial of service in SIPGO by sending oversized Content-Length headers, triggering excessive memory allocation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-pg59-5vwg-4jxq, GO-2026-6550, MINI-44cw-hmm5-fwg2, MINI-7qrg-82rh-jrfc, MINI-cc5w-jhrr-78w5, MINI-f552-47c7-xwwv, MINI-ppvp-jv72-qcqg, MINI-v65x-9556-fccc

## What is CVE-2026-58268?

CVE-2026-58268 is a high-severity denial of service vulnerability in emiago sipgo, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SIPGO is a library for writing SIP services in the GO language. Prior to 1.4.1, ParserStream.parseSingle in sip/parser_stream.go allocates a SIP body buffer from the client-controlled Content-Length header before ParseMaxMessageLength is enforced. An unauthenticated peer can send a stream-transport message over TCP, TLS, WS, or WSS with an oversized declared length, causing excessive memory allocation and denial of service before the body is read. This issue is fixed in version 1.4.1.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-58268?

3 open source packages ship an affected version, including github.com/emiago/sipgo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/emiago/sipgo` | Go | All versions | 1.4.1 |
| `github.com/emiago/sipgo` | Go | All versions | 1.4.1 |
| `github.com/emiago/sipgo` | Go | All versions | 1.4.1 |

## How do I fix CVE-2026-58268?

Upgrade github.com/emiago/sipgo to 1.4.1 or later.

## Is CVE-2026-58268 being exploited?

There is no known exploitation of CVE-2026-58268 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58268 and fix it if it is affected.

What it is: CVE-2026-58268 is a high-severity denial of service vulnerability in emiago sipgo, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58268 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/emiago/sipgo (Go): affected all versions; fixed in 1.4.1
- github.com/emiago/sipgo (Go): affected all versions; fixed in 1.4.1
- github.com/emiago/sipgo (Go): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58268/ (Markdown: https://insights.sbomify.com/CVE-2026-58268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58268
- OSV: https://osv.dev/vulnerability/CVE-2026-58268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58268/
Summaries are generated and may contain mistakes; the official description above is the record.
