# CVE-2026-58269: Sync-in Server has a complete 2FA Bypass via `POST /api/auth/token`

> Attackers with stolen credentials can bypass Two-Factor Authentication on Sync-in Server by using the token endpoint, leading to account takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-92cr-jxw4-5wjg

## What is CVE-2026-58269?

CVE-2026-58269 is a high-severity authentication bypass vulnerability in Sync-in server, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sync-in Server is an open-source platform for file storage, sharing, collaboration, and syncing. Prior to version 2.4.0, `POST /api/auth/token` authenticates with username and password only, then calls `getTokens()`, which returns full access and refresh JWTs without checking whether the account has TOTP 2FA enabled. An attacker with stolen or phished credentials can bypass 2FA in a single request. The parallel login endpoint (`POST /api/auth/login`) correctly enforces 2FA by calling `setCookies(user, res, true)`, which gates on `user.twoFaEnabled`. Version 2.4.0 patches the issue.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-58269?

2 open source packages ship an affected version, including @sync-in/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sync-in/server` | npm | All versions | 2.4.0 |
| `@sync-in/server` | npm | All versions | 2.4.0 |

## How do I fix CVE-2026-58269?

Upgrade @sync-in/server to 2.4.0 or later.

## Is CVE-2026-58269 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58269 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58269 and fix it if it is affected.

What it is: CVE-2026-58269 is a high-severity authentication bypass vulnerability in Sync-in server, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58269 exists.

Affected packages and fixed versions:
- @sync-in/server (npm): affected all versions; fixed in 2.4.0
- @sync-in/server (npm): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58269/ (Markdown: https://insights.sbomify.com/CVE-2026-58269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58269
- OSV: https://osv.dev/vulnerability/CVE-2026-58269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58269/
Summaries are generated and may contain mistakes; the official description above is the record.
