# CVE-2026-58270: Sync-in Server has a ReDoS via Unsanitized Regex in Sync Diff `pathFilters`

> Attackers can cause a denial of service in Sync-in Server by submitting malicious regex patterns that block the event loop.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-jx63-h26r-8cph

## What is CVE-2026-58270?

CVE-2026-58270 is a medium-severity denial of service vulnerability in Sync-in server, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sync-in Server is an open-source platform for file storage, sharing, collaboration, and syncing. Prior to version 2.4.0, the sync diff endpoint compiles a user-supplied string into a `RegExp` with no complexity validation. A catastrophic-backtracking pattern (e.g. `^(a+)+b`) blocks the Node.js event loop, making the entire server unresponsive to all users until the container is restarted. Version 2.4.0 patches the issue.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-58270?

2 open source packages ship an affected version, including @sync-in/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sync-in/server` | npm | All versions | 2.4.0 |
| `@sync-in/server` | npm | All versions | 2.4.0 |

## How do I fix CVE-2026-58270?

Upgrade @sync-in/server to 2.4.0 or later.

## Is CVE-2026-58270 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58270 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58270 and fix it if it is affected.

What it is: CVE-2026-58270 is a medium-severity denial of service vulnerability in Sync-in server, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58270 exists.

Affected packages and fixed versions:
- @sync-in/server (npm): affected all versions; fixed in 2.4.0
- @sync-in/server (npm): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58270/ (Markdown: https://insights.sbomify.com/CVE-2026-58270/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58270
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58270
- OSV: https://osv.dev/vulnerability/CVE-2026-58270

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58270/
Summaries are generated and may contain mistakes; the official description above is the record.
