# CVE-2026-58272: Sync-in Server has Username/Login Enumeration via Timing Side-Channel on POST /api/auth/login (incomplete fix of the prior timing-attack advisory)

> An unauthenticated attacker can enumerate valid usernames via timing side-channels in the login endpoint, facilitating credential stuffing and phishing attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-29hq-23m2-2j47

## What is CVE-2026-58272?

CVE-2026-58272 is a medium-severity vulnerability in Sync-in server, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sync-in Server is an open-source platform for file storage, sharing, collaboration, and syncing. Versions prior to 2.4.1 contain an observable timing discrepancy in the login endpoint because authentication attempts for nonexistent accounts return without performing the bcrypt comparison used for existing accounts. An unauthenticated attacker can measure response times to enumerate valid usernames or email addresses, facilitating credential-stuffing, password-spraying, and phishing attacks. Version 2.4.1 contains a patch.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-58272?

2 open source packages ship an affected version, including @sync-in/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sync-in/server` | npm | All versions | 2.4.1 |
| `@sync-in/server` | npm | All versions | 2.4.1 |

## How do I fix CVE-2026-58272?

Upgrade @sync-in/server to 2.4.1 or later.

## Is CVE-2026-58272 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58272 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58272 and fix it if it is affected.

What it is: CVE-2026-58272 is a medium-severity vulnerability in Sync-in server, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58272 exists.

Affected packages and fixed versions:
- @sync-in/server (npm): affected all versions; fixed in 2.4.1
- @sync-in/server (npm): affected all versions; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58272/ (Markdown: https://insights.sbomify.com/CVE-2026-58272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58272
- OSV: https://osv.dev/vulnerability/CVE-2026-58272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58272/
Summaries are generated and may contain mistakes; the official description above is the record.
