# CVE-2026-5831: Agions taskflow-ai terminal_execute handlers.ts os command injection


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-3xp3-pr8x-f755

## What is CVE-2026-5831?

CVE-2026-5831 is a medium-severity vulnerability in Agions taskflow-ai, published on 9 Apr 2026. 

### Official description

A security flaw has been discovered in Agions taskflow-ai up to 2.1.8. This impacts an unknown function of the file src/mcp/server/handlers.ts of the component terminal_execute. Performing a manipulation results in os command injection. The attack is possible to be carried out remotely. Upgrading to version 2.1.9 will fix this issue. The patch is named c1550b445b9f24f38c4414e9a545f5f79f23a0fe. Upgrading the affected component is recommended. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-5831?

2 open source packages ship an affected version, including taskflow-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `taskflow-ai` | npm | All versions | 2.1.9 |
| `taskflow-ai` | npm | All versions | 2.1.9 |

## How do I fix CVE-2026-5831?

Upgrade taskflow-ai to 2.1.9 or later.

## Is CVE-2026-5831 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5831 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5831 and fix it if it is affected.

What it is: CVE-2026-5831 is a medium-severity vulnerability in Agions taskflow-ai, published on 9 Apr 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5831 exists.

Affected packages and fixed versions:
- taskflow-ai (npm): affected all versions; fixed in 2.1.9
- taskflow-ai (npm): affected all versions; fixed in 2.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5831/ (Markdown: https://insights.sbomify.com/CVE-2026-5831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5831
- OSV: https://osv.dev/vulnerability/CVE-2026-5831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5831/
Summaries are generated and may contain mistakes; the official description above is the record.
