# CVE-2026-58314: Two SSRF findings in Gitea 1.26.2


- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-2fcr-jfvc-vgg2, GO-2026-6038, MINI-67cg-f6xj-gqfh, MINI-vrcc-g22m-q4xr

## What is CVE-2026-58314?

CVE-2026-58314 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. 

### Official description

Two SSRF findings in Gitea 1.26.2

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-58314?

3 open source packages ship an affected version, including code.gitea.io/gitea and gitea.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |

## How do I fix CVE-2026-58314?

Upgrade code.gitea.io/gitea to 1.27.0 or later.

## Is CVE-2026-58314 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58314 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58314 and fix it if it is affected.

What it is: CVE-2026-58314 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58314 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58314/ (Markdown: https://insights.sbomify.com/CVE-2026-58314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58314
- OSV: https://osv.dev/vulnerability/CVE-2026-58314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58314/
Summaries are generated and may contain mistakes; the official description above is the record.
