CVE-2026-58374 Memory corruption in hostapd
An unauthenticated attacker within wireless range can cause a denial of service by sending a crafted Wi-Fi 7 management frame that triggers an out-of-bounds write in hostapd.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-58374?
CVE-2026-58374 is a medium-severity memory corruption vulnerability in w1.fi hostapd, published on 30 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
In hostapd before 2.12, a missing bounds check in AP-mode Wi-Fi 7 (IEEE 802.11be) Multi-Link Operation (MLO) association request processing allows an unauthenticated attacker within wireless range to send a crafted management frame containing a malformed Multi-Link Element or Per-STA Profile subelement. In hostapd_process_ml_assoc_req() in src/ap/ieee802_11_eht.c, the received link_id field can be parsed as value 15, but the corresponding links[] storage only has valid entries for lower link IDs (0 through 14). This causes an out-of-bounds write / small memory corruption during association processing before the 4-way handshake. The attack does not require network credentials, prior authentication, or user interaction. The confirmed practical impact is denial of service through hostapd process termination. This affects hostapd v2.11 and newer development snapshots before v2.12 when built with CONFIG_IEEE80211BE enabled. The issue is fixed in hostapd v2.12 and the upstream 2026-1 fixes.
Weakness: CWE-193
Which versions are affected by CVE-2026-58374?
It affects 1 product.
Linux distribution packages (17)
hostapd AlmaLinux:10 | All versions | 2.11-3.el10_2 |
hostapd AlmaLinux:9 | All versions | 2.11-3.el9_8 |
hostapd Red Hat:enterprise_linux:10.2 | All versions | 0:2.11-3.el10_2 |
hostapd-debuginfo Red Hat:enterprise_linux:10.2 | All versions | 0:2.11-3.el10_2 |
hostapd-debugsource Red Hat:enterprise_linux:10.2 | All versions | 0:2.11-3.el10_2 |
hostapd Red Hat:enterprise_linux:9::appstream | All versions | 0:2.11-3.el9_8 |
hostapd-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:2.11-3.el9_8 |
hostapd-debugsource Red Hat:enterprise_linux:9::appstream | All versions | 0:2.11-3.el9_8 |
hostapd Rocky Linux:10 | All versions | 0:2.11-3.el10_2 |
hostapd Rocky Linux:9 | All versions | 0:2.11-3.el9_8 |
wpa_supplicant SUSE:Linux Enterprise Server 16.0 | All versions | 2.11-160000.4.1 |
wpa_supplicant SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 2.11-160000.4.1 |
wpa_supplicant SUSE:Linux Micro 6.2 | All versions | 2.11-160000.4.1 |
hostapd openSUSE:Leap 16.0 | All versions | 2.11-bp160.3.1 |
wpa_supplicant openSUSE:Leap 16.0 | All versions | 2.11-160000.4.1 |
hostapd openSUSE:Tumbleweed | All versions | 2.11-4.1 |
wpa_supplicant openSUSE:Tumbleweed | All versions | 2.11-7.1 |
Products include W1.fi Hostapd.
How do I fix CVE-2026-58374?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-58374 being exploited?
There is no known exploitation of CVE-2026-58374 in the wild and no public exploit code.
Other vulnerabilities in w1.fi hostapd
Sources
Also known as ALSA-2026:85276, ALSA-2026:85277, CLSA-2026-1784037722, GHSA-f38w-mwf7-vv8p, RHSA-2026:85276, RHSA-2026:85277 and 8 more.